GNOME Bugzilla – Bug 336110
move taglib-based ID3 muxer to -good
Last modified: 2006-05-01 18:02:02 UTC
I would like to move the taglib-based ID3 muxer from -bad to -good. Going through the checklist: * I am willing to actively maintain the element, but I'm sure that Christophe (who has written it originally) would be equally willing to maintain it. * plugin's code: - base class: N/A - uses boilerplate macros - conforms to GStreamer coding style - has a custom debug category - uses GST_*_OBJECT where possible * compiled plugin - shows up properly in gst-inspect * is in the correct location (/ext) * documented: - correct element description and plugin description - has a gtk-doc blurb with pipeline example * unit tests: - will be attached below - test is leak-free with valgrind * license: - plugin code is LGPL - taglib is LGPL * docs will be added to the build once it is actually in the -good repository. Some CVS surgery to do the move would be nice, but is not essential. In the course of the move, I would also like to rename the source files: gsttaglib.cc => gsttaglibmux.cc gsttaglib.hh => gsttaglibmux.hh
Created attachment 62063 [details] stand-alone test for id3v2mux Stand-alone unit test for id3v2mux. Proof of existence and workiness. Will be changed to use the check framework when transition is done.
Created attachment 62103 [details] stand-alone test for id3v2mux using check framework Updated to use check framework
I was looking at this. Noticing the following things: - gtkdoc-mkdb does not look in .cc files for documentation. That's pretty damn annoying :) - the plugin is called taglib and the element is called tagid3v2mux. However the class for the element is called GstTagLibClass. And the debugging category is again something with ID3 in it. This should be cleaned up; either the idea is to add other types of tag adders, in which case the classes should be named ID3V2Mux-alike, or it is never going to do anything else than id3. Also, if we have id3demux to demux, I think this element should be named tagid3v2mux and not just id3v2mux. - the check was put in -bad, with an ugly hack to find the "good" plugins (for id3demux) - can this be written without relying on id3demux at all?
Thanks for looking at this. I agree it should be called tagid3v2mux and not id3v2mux. At some point in the future I'd like to add a taglib-based APE tag muxer as well, that's why I'd prefer to keep the class/filename more general for now (when that happens I'd probably split the ID3v2 stuff out into a new subclass and add another subclass for the APE stuff). Of course you can write tests without relying on the id3demux plugin, but those wouldn't be very useful kinds of tests, or at least I can't think of any right now.
moved.