After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 793949 - fix crash when some external APIs fail
fix crash when some external APIs fail
Status: RESOLVED OBSOLETE
Product: empathy
Classification: Core
Component: Notifications
3.25.x
Other Linux
: Normal normal
: ---
Assigned To: empathy-maint
empathy-maint
Depends on:
Blocks:
 
 
Reported: 2018-03-01 02:24 UTC by Zhouyang
Modified: 2018-05-22 19:19 UTC
See Also:
GNOME target: ---
GNOME version: ---


Attachments
patch of the potential API bugs (1.01 KB, patch)
2018-03-01 02:24 UTC, Zhouyang
none Details | Review

Description Zhouyang 2018-03-01 02:24:39 UTC
Created attachment 369129 [details] [review]
patch of the potential API bugs

Hi,

I'm a PhD student. I analyzed the empathy source code and found some potential API bugs that may cause crashes.

These crashes are mainly caused by insufficient error handling of API functions like notify_init or pa_context_connect.

I think it's unsafe to assume the library function would be correct. It would be better if we could handle the error properly.

Attached please find the patch against version current development version. Hopefully, it can solve these potential bugs.

Best,
Zhouyang
Comment 1 GNOME Infrastructure Team 2018-05-22 19:19:46 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to GNOME's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.gnome.org/GNOME/empathy/issues/909.