After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 792168 - crash when changing font of text input manually
crash when changing font of text input manually
Product: GIMP
Classification: Other
Component: General
Other Linux
: Normal critical
: ---
Assigned To: GIMP Bugs
Depends on:
Reported: 2018-01-03 15:14 UTC by heavytull
Modified: 2018-05-24 18:58 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description heavytull 2018-01-03 15:14:40 UTC
when using the text tool, changing the font or font size manually, for example clicking into one of the fields for edition and they pressing any key like "backward", "shift" only, or an alphanumeric key makes it crashing. I tried on both a loaded image and a newly created blank image, and I tried even from a newly created user account, the result is the same in all cases. Below is the error output from the terminal window:

(gimp:3549): Gdk-WARNING **: gdkdrawable-x11.c:874 drawable is not a pixmap or window

(script-fu:3744): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): error
Segmentation fault
Comment 1 Michael Schumacher 2018-01-03 15:16:27 UTC
Does this also happen with a more recent version of GIMP? The current stable is 2.8.22.
Comment 2 heavytull 2018-01-06 19:23:54 UTC
I'm using the binary package provided by my distro, so it will be some work to go to another version. But if you can prove that this problem might will have been resolved in between let me know, i'll probably think about doing the work. Gimp looks like a deliberately low graded tool and full of problems. It's a huge work to report all of them. It very often crashes. another good example of such is LibreOffice, which is far worse.
Comment 3 GNOME Infrastructure Team 2018-05-24 18:58:25 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to GNOME's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: