After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 784442 - Improving the tvdb source with episode's specific metadata
Improving the tvdb source with episode's specific metadata
Status: RESOLVED OBSOLETE
Product: grilo
Classification: Other
Component: core
unspecified
Other All
: Normal normal
: ---
Assigned To: grilo-maint
grilo-maint
Depends on:
Blocks:
 
 
Reported: 2017-07-02 08:18 UTC by Victor Toso
Modified: 2018-09-24 09:54 UTC
See Also:
GNOME target: ---
GNOME version: ---


Attachments
core: Add GRL_METADATA_KEY_EPISODE_OVERVIEW (4.38 KB, patch)
2017-07-02 08:18 UTC, Victor Toso
needs-work Details | Review
core: Add GRL_METADATA_KEY_EPISODE_AIRED_DATE (4.43 KB, patch)
2017-07-02 08:18 UTC, Victor Toso
needs-work Details | Review
thetvdb: better expose episode specific metadata (11.66 KB, patch)
2017-07-02 08:19 UTC, Victor Toso
none Details | Review

Description Victor Toso 2017-07-02 08:18:04 UTC
It'll be necessary for WIP totem's series UI.
https://github.com/Kekun/totem-series
Comment 1 Victor Toso 2017-07-02 08:18:08 UTC
Created attachment 354789 [details] [review]
core: Add GRL_METADATA_KEY_EPISODE_OVERVIEW

This metadata-key defines the overview of an episode of a TV Show.
Including this metadata-key avoids overload of
GRL_METADATA_KEY_DESCRIPTION.
Comment 2 Victor Toso 2017-07-02 08:18:14 UTC
Created attachment 354790 [details] [review]
core: Add GRL_METADATA_KEY_EPISODE_AIRED_DATE

This metadata-key defines the aired date of an episode of a TV Show.
Including this metadata-key avoids overload of
GRL_METADATA_KEY_PUBLICATION_DATE.
Comment 3 Victor Toso 2017-07-02 08:19:46 UTC
Created attachment 354791 [details] [review]
thetvdb: better expose episode specific metadata

This patch tries to address the overload of four metadata-keys that
can have their meaning to the TV Show or to any of its episodes:
 * GRL_METADATA_KEY_PUBLICATION_DATE
 * GRL_METADATA_KEY_DESCRIPTION
 * GRL_THETVDB_METADATA_KEY_THETVDB_ID
 * GRL_THETVDB_METADATA_KEY_IMDB_ID

In Grilo v0.3.4, two new metadata-keys were added to the core:
 * GRL_METADATA_KEY_EPISODE_OVERVIEW -> replaces "description"
 * GRL_METADATA_KEY_EPISODE_AIRED_DATE -> replaces "publication-date"

To solve the problem entirely, this patch also creates two new
metadata-keys:
 * GRL_THETVDB_METADATA_KEY_EPISODE_THETVDB_ID
 * GRL_THETVDB_METADATA_KEY_EPISODE_IMDB_ID

Tests were fixed to comply with the changes.
Comment 4 Bastien Nocera 2017-07-02 20:00:49 UTC
Review of attachment 354789 [details] [review]:

::: src/data/grl-media.c
@@ +1909,3 @@
+ * @episode_overview: the overview of the episode
+ *
+ * Sets the title of an media

copy/paste error.

@@ +3405,3 @@
+ * @media: the media instance
+ *
+ * Returns: the overview of the episode

What's an "overview"? A synopsis? A summary of the episode? The complete story? With or without spoilers?
Comment 5 Bastien Nocera 2017-07-02 20:03:21 UTC
Review of attachment 354790 [details] [review]:

I'm not sure whether this allows for per-territory dates either. If it doesn't, it probably needs to be "original air date"

::: src/grl-metadata-key.c
@@ +378,2 @@
   grl_registry_register_metadata_key_system (registry,
+                                             g_param_spec_string ("episode-aired-date",

Why isn't this a G_TYPE_DATE_TIME property?
Comment 6 Bastien Nocera 2017-07-02 20:13:27 UTC
I can understand having better names for those:
 * GRL_METADATA_KEY_PUBLICATION_DATE
 * GRL_METADATA_KEY_DESCRIPTION
but wouldn't a #define or alias be as effective? Is this supposed to make the API nicer, or the internal code more understandable?

But for those:
 * GRL_THETVDB_METADATA_KEY_THETVDB_ID
 * GRL_THETVDB_METADATA_KEY_IMDB_ID

I don't really understand why it's confusing to have a tvdb of the episode if the GrlMedia represents an episode, and of the series if the GrlMedia represents a series.

Because I can already see the need to represent a season as well.

The API for the "Totem TV series" widget can take different routes. My favourite one is having a GrlContainer represent a series, or a season. This GrlMedia will be used to create the overall page, and each of the items within the container will be used for their own list item.
Comment 7 GNOME Infrastructure Team 2018-09-24 09:54:24 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to GNOME's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.gnome.org/GNOME/grilo/issues/119.