After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 744762 - Using TAGFILES prevents symbol extraction
Using TAGFILES prevents symbol extraction
Product: doxygen
Classification: Other
Component: general
Other Linux
: Normal major
: ---
Assigned To: Dimitri van Heesch
Dimitri van Heesch
Depends on:
Reported: 2015-02-18 21:38 UTC by account
Modified: 2015-06-27 19:01 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description account 2015-02-18 21:38:09 UTC
When using a tagfile generated for another project some symbols from the current project are not being extracted anymore.

I have created a minimal example to reproduce the problem:

Project "foo" defines a function `bar::foo:foo_func()`.

Project "bar" defines a function bar::bar_func().

When being documented separately both generated html pages show the namespaces and functions correctly.

But when "bar" uses the tagfile generated by the project "foo" doxygen does not extract the symbols in "bar" anymore. Therefore it does not generate a namespace page anymore.
Comment 1 William Woodall 2015-06-02 17:38:08 UTC
Comment 2 Esteve Fernandez 2015-06-02 17:53:13 UTC
Comment 3 Dimitri van Heesch 2015-06-06 09:09:57 UTC
Is this problem limited to version 1.8.6, or does it also occur in version
Comment 4 account 2015-06-08 21:30:09 UTC
I just tried it with Doxygen 1.8.8 ( which is available for Ubuntu Utopic and the problem is the same.

I could not try the 1.8.9 packages from Ubuntu Vivid / Wily since they require a different libstdc++ version which I can't install on Trusty that easy. Can you try to run the simple example I provided with doxygen 1.8.9?
Comment 5 account 2015-06-08 21:55:39 UTC
I just got my hand on an Vivid machine which has doxygen and I can confirm that the problem is still the same as with the other versions.
Comment 6 Dimitri van Heesch 2015-06-11 19:23:48 UTC
Confirmed. Should be fixed in with latest GIT commit:
Comment 7 Dimitri van Heesch 2015-06-27 19:01:47 UTC
This bug was previously marked ASSIGNED, which means it should be fixed in
doxygen version 1.8.10. Please verify if this is indeed the case. Reopen the
bug if you think it is not fixed and please include any additional information 
that you think can be relevant (preferably in the form of a self-contained example).