After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 703090 - Port to Wayland
Port to Wayland
Product: pitivi
Classification: Other
Component: User interface
Other Linux
: Normal enhancement
: Git
Assigned To: Pitivi maintainers
Pitivi maintainers
Depends on:
Reported: 2013-06-26 01:11 UTC by Jean-François Fortin Tam
Modified: 2015-10-20 13:16 UTC
See Also:
GNOME target: ---
GNOME version: ---

Description Jean-François Fortin Tam 2013-06-26 01:11:01 UTC
As the title says.

There is an initial patch from Lubosz here:

...but I have not tested it, nor do I know if this is considered the "proper" fix. There are probably other issues but I'm not aware of them yet. Help (testing and patches) welcome.
Comment 1 Lubosz Sarnecki 2013-06-28 15:31:28 UTC
Pitivi crashes currently with this gobject introspection related issue

/usr/lib/python2.7/site-packages/gi/ Warning: invalid cast from 'GdkWaylandDisplay' to 'GdkX11Display'
  return info.invoke(*args, **kwargs)

Funny thing that this minimal example works in wayland:

There is no reference to GdkX11Display in the Pitivi code. I am trying to figure out what causes this. It also has worked once ;)
Comment 2 Lubosz Sarnecki 2013-06-28 15:40:48 UTC
Another thing to be implemented would be a set_window_handle method in the waylandsink in gst-plugins-bad, so it could place the sink into the Wayland GDK window. Like xvimagesink in plugins-base does for a GDK X window.
Comment 3 Tomeu Vizoso 2013-06-28 15:52:42 UTC
(In reply to comment #1)
> There is no reference to GdkX11Display in the Pitivi code. I am trying to
> figure out what causes this. It also has worked once ;)

A gdb backtrace with G_DEBUG=fatal-warnings would be interesting. I suspect an override in pygobject.
Comment 4 Lubosz Sarnecki 2013-06-28 16:16:45 UTC
The crash was solved by starting PiTiVi like this:

CLUTTER_BACKEND=wayland ./bin/pitivi

GDK_BACKEND=wayland is also set.
It starts now (with my patch from the first post), the viewer is detached and the timeline is not rendered. So stuff cannot be added.
Comment 5 Lubosz Sarnecki 2013-06-28 16:20:20 UTC
This it how it looks
Comment 6 Thibault Saunier 2015-10-20 13:16:01 UTC
This bug has been migrated to

Please use the Phabricator interface to report further bugs by creating a task and associating it with Project: Pitivi.

See for details.