After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 322501 - Imprecise error messages for rare SSH errors
Imprecise error messages for rare SSH errors
Product: nautilus
Classification: Core
Component: general
Other All
: Low major
: future
Assigned To: Nautilus Maintainers
Nautilus Maintainers
Depends on:
Reported: 2005-11-26 16:24 UTC by Uri David Akavia
Modified: 2015-12-25 09:17 UTC
See Also:
GNOME target: ---
GNOME version: 2.13/2.14

Description Uri David Akavia 2005-11-26 16:24:58 UTC
Version details: 2.10.1
Distribution/Version: Debian Testing

1.Connect to a ssh server (note that pressing connect has absolutely no effect
with regards to network trafic)
2.Attempt to open the newly created server (minor network traffic)
3.Get error that says "Cannot display location 'sftp://user@server'. Details:
There is no default action associated with this location."

Expected result: The SSH share opens, asking me for password, if necessary

When does this happen: Always
I'm using a vanilla Debian system, with Gnome 2.10.
Comment 1 Christian Neumair 2005-12-21 22:24:46 UTC
Thanks for your bug report!
Maybe you could check the output of
gnomevfs-info sftp://user@server
Comment 2 Uri David Akavia 2005-12-22 09:48:30 UTC
$gnomevfs-info sftp://user@server
Error: I/O error
This might be because I'm apparently on the banned list for that server.

Using another server (which also doesn't work in Nautilus) gives me
Error: Access denied

This is incorrect, since ssh user@server2 works great. user@server2 fails in Nautilus in a slightly different manner - all numbered steps are identical, but Nautilus asks me for a password before moving on to step 3.

There might be something wierd about this specific server as well. It is a gateway, which only allows you to ssh onward.

Do you have a server which should work, so I can try to determine what is going on?
Comment 3 Uri David Akavia 2005-12-22 09:55:10 UTC
BTW, I'm working on reinstating my permissions for server1, and will update as soon as terminal ssh works (which I seem to recall worked when I opened the bug).
Comment 4 Christian Neumair 2005-12-22 12:18:42 UTC
Remember to also enter the login password into the console, like
 gnomevfs-info sftp://user:passwd@host
Comment 5 Uri David Akavia 2005-12-27 17:53:54 UTC
Once I've reinstated my permissions, it works for server1.
However, server2 doesn't work. server2 is a special case (since it is a gate which only allows sshing to another server and does not allow ls), but it gives the same error in Nautilus which is wrong.

gnomevfs-info gives
Error: Access denied
I *do* have access, only ls is denied.

I think the bug should be reopened, with a title of "Nautilus gives uniformative errors when connecting to (ssh) server fails - I believe Nautilus should not have given the error I got anyway, and perhaps it should have given a different error every time.
Comment 6 Christian Neumair 2005-12-28 11:24:02 UTC
Thanks for your feedback!

What precise error message do you expect? Your initial report was about "no default action associated", now you claim that "access denied" is wrong - which wasn't the initial error message. I'm interested in why the "no default action associated" was shown at all, because it sounds wrong in this context.

On the "access denied" issue: Am I right that your current problem is that the directory has +r but -x permissions, and you think that the "Access denied" message is not appropriate in this case? What else would you expect? Technically, only the listing of the contents is not allowed, but access is granted. I'm not sure how we can tell this the unexperienced users without confusing them.
Comment 7 Uri David Akavia 2005-12-29 17:19:14 UTC
Right, I'll try to be more clear.

Server1 (IP is banned)
ssh: remote host has closed connection (give or take, I'm not sure of the exact phrasing)
gnomevfs-info: Access Denied
This is incorrect (at least partly). A better error would be "Connection Failed"
Nautilus: Cannot display location 'sftp://user@server1'. Details:
There is no default action associated with this location.
This is INCORRECT and misleading. It should say something like "There was a problem connecting to this location/server. Please try again in a few minutes and contact your administrator if the problem continues." The current error message gives the (mistaken) impression that Nautilus does not support sftp.

server2 (gateway)
ssh: Logs in succesfully. Prints out a message (README of the server) stating that this server is a gateway, and that the allowed commands include SSH, Rlogin, telnet.
gnomevfs-info: Access Denied.
This seems at least partly incorrect, since the user/password combinations were correct, but running the "ls" command (or whatever command is run at this point) was denied. Slightly confusing, since it gives the impression that the user misspelled his password. Perhaps a better error would be "Protocol not supported"
Nautilus: Cannot display location 'sftp://user@server1'. Details:
There is no default action associated with this location.
Again, this is incorrect and misleading for the reasons given. However, it would be better to give a different error in this situation compared to the first situation.

I'm guessing that gnomevfs-info is not the responsibility of Nautilus maintainers, so should I open another bug?
Comment 8 Christian Neumair 2006-01-06 11:51:10 UTC
> I'm guessing that gnomevfs-info is not the responsibility of Nautilus
maintainers, so should I open another bug?

Yes, please do so. I'm marking the priority as low because this is really a rare case. Usually, ssh server configurations seem to be that obscure quite seldom.
Comment 9 Sebastien Bacher 2006-04-28 19:48:39 UTC
Ubuntu but about that:
Comment 10 Mystilleef 2007-02-22 01:04:40 UTC
I'm not sure if this bug report addresses the problem I'm having. But I'm getting an "access denied" error when trying to access my sourceforge server. I used to be able to access it via nautilus, so I don't know what went wrong. I'm using Nautilus 2.17.91. Calling gnomevfs-info on the server path also gives me the same error. I also can't use applications that use gnomevfs to access the same server.

Comment 11 Luigi Maselli 2007-06-14 19:46:20 UTC
very annoying..

a workaround from ubuntu bugs:

You also come across that error message when you have several SSH servers on different ports behind one IP.

The only way I found to temporarily handle that problem is to empty /home/user/.ssh/known_hosts and chmod 000 it.

This way, you always get prompted by nautilus as if it was the first time you were connecting.

Not the safest workaround.. subject to man in the middle attacks if you're accepting SSHv1 and allow password authentication.
Comment 12 Cosimo Cecchi 2008-04-16 10:07:56 UTC
Dear reporters,
could you try if this is still an issue with Nautilus 2.22.x and GVfs? Thanks.
Comment 13 Ofir 2008-08-23 23:41:42 UTC
Is someone working on this bug?

It keeps preventing me (and I guess many others) from using nautilus to ssh to some hosts.

gnomevfs-info output (this server requires password):
Name              : /
Type              : Directory
MIME type         : x-directory/normal
Default app       : nautilus-folder-handler.desktop
Size              : 1024
I/O block size    : 262144
Local             : NO
SUID              : NO
SGID              : NO
Sticky            : NO
Permissions       : 40755
Access time       : Sat Aug 23 03:57:07 2008
Modification time : Wed Apr  2 12:05:24 2008

I don't really know how this server works but it is the server of a university (big one, so I guess they have many servers).
Comment 14 Cosimo Cecchi 2008-08-24 17:55:49 UTC
Ofir: which version of Nautilus are you using? If you are using something older than 2.22, could you please try with a newer version (i.e. >= 2.22.x)? Thanks.
Comment 15 Ofir 2008-08-24 20:40:48 UTC
I am using Ubuntu 8.04 with the lastest updates:
nautilus --version
GNOME nautilus 2.22.3
Comment 16 Marcus Carlson 2010-07-05 21:56:00 UTC
Ofir, could you try with a recent version once again? This time with something like 2.30?

If it's still a problem I think we should move this one to gvfs.
Comment 17 Tobias Mueller 2010-09-12 15:53:42 UTC
Closing this bug report as no further information has been provided. Please feel free to reopen this bug if you can provide the information asked for.
Comment 18 derek 2015-12-25 09:17:19 UTC
confirm in Ubuntu-15.10 (gnome 3.18) this bug still exists. in gnome3 nautilus how to invalidate the ssh host cache?

I can remove ~/.ssh/known_hosts (or by ssh-keygen -R ... that particular host) that resolved ssh command line login only; but in the file manager (nautilus) it prompts this error message, and I don't know where nautilus save the ssh host key cache? and how to invalidate

Oops! Something went wrong.
Unhandled error message: Host key verification failed