After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 312757 - Evince CVS HEAD strange issues when printing exactly one page.
Evince CVS HEAD strange issues when printing exactly one page.
Product: evince
Classification: Core
Component: general
git master
Other Linux
: Normal critical
: ---
Assigned To: Evince Maintainers
Evince Maintainers
: 312758 317957 (view as bug list)
Depends on:
Reported: 2005-08-06 12:23 UTC by Ali Akcaagac
Modified: 2006-04-05 04:47 UTC
See Also:
GNOME target: ---
GNOME version: 2.11/2.12

PICTURE1 (103.98 KB, image/png)
2005-08-06 12:24 UTC, Ali Akcaagac
PICTURE2 (32.59 KB, image/png)
2005-08-06 12:24 UTC, Ali Akcaagac
PICTURE3 (49.89 KB, image/png)
2005-08-06 12:25 UTC, Ali Akcaagac
PICTURE4 (57.01 KB, image/png)
2005-08-06 12:26 UTC, Ali Akcaagac
The file that causes this issue (117.35 KB, application/octet-stream)
2005-09-11 17:49 UTC, Ali Akcaagac
PICTURE5 (197.27 KB, image/png)
2005-09-11 17:54 UTC, Ali Akcaagac
Details (15.88 KB, application/octet-stream)
2005-09-11 17:56 UTC, Ali Akcaagac

Description Ali Akcaagac 2005-08-06 12:23:52 UTC
I have been encountering some weirdness with recent version of Evince. But I
tend to believe that this is a libgnomeprint/ui/ libgnomecups issue but I am not
sure so I file it here and forward a report to the libgnomeprint people too.

I have a document that when loaded looks like under >>> PICTURE1 <<<.

When I now want to print exactly the first page and I select a range from 1 to 1
in the libgnomeprintui dialog I end up getting a printout that looks like under
>>> PICTURE4 <<< please pay attention to the looks of the font.

I tested around a bit and printed the same document and only the first page
using ghostscript and kpdf and the printout was ok.

I experimented around and used libgnomeprint/ui to save this document COMPLETELY
as PS into a file named please see >>> PICTURE2 <<<.

When the entire document got saved the output looked like >>> PICTURE3 <<< well
it was ok.

Then I saved the same document again using libgnomeprint/ui again as PS file and
again as but only the first page (selecting range 1 to 1) and it ended
up like under >>> PICTURE4 <<< the same as my printout.

I am also getting an warning output like this:

galaxy@ulixys:~ > evince /.quader/.cdram/mnt/stuff/CTRAPS.PDF

(evince:1864): GnomePrintCupsPlugin-WARNING **: iconv does not support ppd
character encoding: ISOLatin1, trying CSISOLatin1
galaxy@ulixys:~ >

I also get the same output with gedit and other programs that use
libgnomeprint/ui. There is no font issues or anything, I already checked that
one up. Please have a look and in doubt forward this error report to the correct
Comment 1 Ali Akcaagac 2005-08-06 12:24:19 UTC
Created attachment 50314 [details]
Comment 2 Ali Akcaagac 2005-08-06 12:24:40 UTC
Created attachment 50315 [details]
Comment 3 Ali Akcaagac 2005-08-06 12:25:10 UTC
Created attachment 50316 [details]
Comment 4 Ali Akcaagac 2005-08-06 12:26:26 UTC
Created attachment 50317 [details]

Ok and here the last picture. I know that this has been happening recently, so
only one of the recent changes either in EVINCE (which I doubt) or in
libgnomeprint/ui libgnomecups (which I believe more) can be the cause.
Comment 5 Ali Akcaagac 2005-08-06 12:30:15 UTC
I filed a bug
Comment 6 Christian Kirbach 2005-08-12 10:39:47 UTC
*** Bug 312758 has been marked as a duplicate of this bug. ***
Comment 7 Jody Goldberg 2005-08-12 18:19:34 UTC
The warning is ignoreable, but you results are worrying.
I'd like to see
  - the input file
  - the resulting ps & pdf files when printing jsut the first page.
Comment 8 Ali Akcaagac 2005-09-11 17:49:39 UTC
Created attachment 52092 [details]
The file that causes this issue

The file is called 'CTRAPS.PDF'. But I also got this problem with other *.pdf
files that I wanted to print exactly one page from.
Comment 9 Ali Akcaagac 2005-09-11 17:54:27 UTC
Created attachment 52093 [details]

I updated Evince and Poppler and now I even get the *.pdf file rendered like
this. Look PICTURE1 and now look at this one PICTURE5. But with older Evince
PICTURE1 was ok, and printout of the whole thing was ok too, but printing one
page results in the stuff that looks like PICTURE5.
Comment 10 Ali Akcaagac 2005-09-11 17:56:37 UTC
Created attachment 52094 [details]

And here exactly the first page of above document printed into a postscript
file. Look how's it looking.
Comment 11 Christian Kirbach 2005-10-07 13:06:19 UTC
Reopening as Jody's request has been answered.
Comment 12 Kjartan Maraas 2005-10-10 13:17:43 UTC
Same thing here with evince 0.4.0 and poppler 0.4.2
Comment 13 Kjartan Maraas 2005-10-11 17:49:28 UTC
*** Bug 317957 has been marked as a duplicate of this bug. ***
Comment 14 Ali Akcaagac 2005-11-06 00:24:45 UTC
Can we see some progress in this area ? It's quite annoying when using Evince to
print out letters or stuff for work/school or university.
Comment 15 Martin Kretzschmar 2005-12-18 16:38:22 UTC
Can you try the patch from please (or try poppler 0.4.3)?

This is just for the print problem, not the PICTURE5 problem, please try with an evince/poppler that doesn't have the PICTURE5 problem
Comment 16 Christian Neumair 2006-04-03 11:52:16 UTC
Setting to NEEDINFO. Ali: Maybe you could try out poppler 0.4.3 or later?
Comment 17 Ali Akcaagac 2006-04-04 04:13:30 UTC

I am using Poppler 0_4_X branch at the moment, I wasn't able to test whether the printing issues have been solved due to my short time recently. But as a sidenote. I am not able to compile Poppler from HEAD. I run into big errors running the file to generate a running configure file. It usually throws out macros not found issues such as QT_blah not found. or JPEG_blah not found during the process of building the configure file. I think some KDE guy totally messed up the entire configure thing.
Comment 18 Ali Akcaagac 2006-04-04 21:49:06 UTC
It looks like it works. Did some printouts today, but I was in a hurry so I need to reinvestigate a bit more and report back. Thanks for the patience (I am stuck in a 65 hrs/week job as java-Engineer at a large and top 50 corporate)!
Comment 19 Nickolay V. Shmyrev 2006-04-05 04:47:08 UTC
Ok, thanks to Ali for report and testing.