After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 756760 - Tracer framework reuses existing GST_TRACE environment variable
Tracer framework reuses existing GST_TRACE environment variable
Status: RESOLVED FIXED
Product: GStreamer
Classification: Platform
Component: gstreamer (core)
git master
Other Linux
: Normal normal
: 1.7.1
Assigned To: GStreamer Maintainers
GStreamer Maintainers
Depends on:
Blocks:
 
 
Reported: 2015-10-17 19:17 UTC by Sebastian Dröge (slomo)
Modified: 2015-10-20 07:51 UTC
See Also:
GNOME target: ---
GNOME version: ---



Description Sebastian Dröge (slomo) 2015-10-17 19:17:51 UTC
See summary, not necessarily a problem but might be confusing... especially if someone wants to create a tracer plugin called live or live-mem.
Comment 1 Tim-Philipp Müller 2015-10-17 20:02:34 UTC
I'd probably rename the env var used by the alloc tracer (which is something we no longer expose officially).
Comment 2 Sebastian Dröge (slomo) 2015-10-18 08:17:37 UTC
I know that people are actually using the alloc-trace stuff, and I also used it yesterday. We could make "live" and "live-mem" reserved names that can't be used by tracer plugins.
Comment 3 Stefan Sauer (gstreamer, gtkdoc dev) 2015-10-18 09:34:57 UTC
Or I just change mine to GST_TRACER. Maybe we can turn the alloctrace stuff into a tracer plugin in the long run and deprecate it. Then we can remove this in gst-2.0
Comment 4 Tim-Philipp Müller 2015-10-18 09:50:31 UTC
The alloctrace stuff is not public API in 1.x, it's just there still for now. People use it interactively for debugging, I'm sure it's ok to just tell them to use another environment variable name to use if we wanted to?

Having said that, perhaps we should bikeshed the GST_TRACE name a bit more :)
Comment 5 Thiago Sousa Santos 2015-10-19 17:53:03 UTC
GST_TRACER_PLUGINS looks more meaningful and readable to me, but I'm fine with GST_TRACE or GST_TRACER
Comment 6 Stefan Sauer (gstreamer, gtkdoc dev) 2015-10-19 19:52:28 UTC
commit 70d2a676af2bc51ed7b828dfd762b506bb82083b
Author: Stefan Sauer <ensonic@users.sf.net>
Date:   Mon Oct 19 21:39:19 2015 +0200

    tracer: rename the envvar to GST_TRACER_PLUGINS
    
    The subsystem reused the GST_TRACE var that is already in use by the alloc tracer.
    Fixes #756760

It would be nice to have some notes for how to use the alloc_trace stuff. If I get it, it counts the number of instances per type and can also build a list of the content. Finally the atexit handler dumps the leaked data. All this could be done with the tracing subsystem too, except that I did not use an atexit handler so far. I can take a stab at converting this into a tracer plugin, if that sounds like a good idea.

The main change would be that code like this:
#ifndef GST_DISABLE_TRACE
  _gst_alloc_trace_new (_gst_mini_object_trace, mini_object);
#endif
would be changed into a trace-point (that can also be used by other tracer plugins).
Comment 7 Tim-Philipp Müller 2015-10-19 19:57:17 UTC
I'd prefer _MODULES to _PLUGINS myself, since the fact that they're a plugin is an implementation detail *ducks* :)
Comment 8 Sebastian Dröge (slomo) 2015-10-20 07:05:28 UTC
Me too, but whatever works!
Comment 9 Stefan Sauer (gstreamer, gtkdoc dev) 2015-10-20 07:51:02 UTC
Feel free to change it. I just wanted to fix the conflict for now.