After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 699121 - Missing tooltips on bottom preview navbar buttons
Missing tooltips on bottom preview navbar buttons
Status: RESOLVED FIXED
Product: gnome-documents
Classification: Core
Component: general
unspecified
Other Linux
: Normal enhancement
: ---
Assigned To: GNOME documents maintainer(s)
GNOME documents maintainer(s)
Depends on:
Blocks:
 
 
Reported: 2013-04-28 11:55 UTC by Alessandro Campagni
Modified: 2013-04-29 19:41 UTC
See Also:
GNOME target: ---
GNOME version: ---


Attachments
patch adding tooltips (1.16 KB, patch)
2013-04-28 11:56 UTC, Alessandro Campagni
needs-work Details | Review
modified after hints received (1.75 KB, patch)
2013-04-28 21:35 UTC, Alessandro Campagni
needs-work Details | Review
One Patch to rule them all! (1.68 KB, patch)
2013-04-28 22:07 UTC, Alessandro Campagni
committed Details | Review

Description Alessandro Campagni 2013-04-28 11:55:26 UTC
The leftmost buttons are missing tooltips.

I don't know a proper name for them but i guess the first could be 'Contents' and the second 'Add bookmark'
Comment 1 Alessandro Campagni 2013-04-28 11:56:28 UTC
Created attachment 242706 [details] [review]
patch adding tooltips
Comment 2 Cosimo Cecchi 2013-04-28 21:18:53 UTC
Review of attachment 242706 [details] [review]:

Thanks for the patch! Looks mostly good, with some comments.

::: src/preview.js
@@ +590,3 @@
                                       valign: Gtk.Align.CENTER
                                     });
+        button.set_tooltip_text('Contents');

You can set the tooltip text as part of the constructor above, like

let b = new Gtk.Button({ tooltip_text: 'text', ... });

The text there should also be marked for translation using gettext(). For brevity, GNOME has a convention of defining a "_()" macro to mark string for translation (see the imports section at the top of preview.js). In Documents we also use double quotes for translatable strings inside _().

Finally, I think "Bookmarks" would be a better name - the table of contents links are essentially glorified bookmarks.

@@ +599,3 @@
                                         valign: Gtk.Align.CENTER
                                       });
+        button.set_tooltip_text('Add bookmark');

I'd call it "Bookmark this page"
Comment 3 Alessandro Campagni 2013-04-28 21:25:24 UTC
Cool! I'll fix it and send another patch.

Thanks for your 'teachingfull' comment!
Comment 4 Alessandro Campagni 2013-04-28 21:35:22 UTC
Created attachment 242752 [details] [review]
modified after hints received
Comment 5 Cosimo Cecchi 2013-04-28 21:52:29 UTC
Review of attachment 242752 [details] [review]:

Looks good to me
Comment 6 Cosimo Cecchi 2013-04-28 21:53:27 UTC
Comment on attachment 242752 [details] [review]
modified after hints received

Err, actually you should squash the two patches together into a single one.
Comment 7 Alessandro Campagni 2013-04-28 22:07:25 UTC
Created attachment 242753 [details] [review]
One Patch to rule them all!
Comment 8 Cosimo Cecchi 2013-04-28 22:20:32 UTC
Review of attachment 242753 [details] [review]:

Yes.
Comment 9 Cosimo Cecchi 2013-04-29 19:41:15 UTC
Pushed this to git master now, thanks!