GNOME Bugzilla – Bug 681681
childproxy: make gst_child_proxy_lookup() take a GstChildProxy instead of GObject ?
Last modified: 2012-08-13 09:40:57 UTC
I think gst_child_proxy_lookup() should either be made a GstChildProxy method, and take a GstChildProxy as first argument, or be renamed. Or both, with a utility function somewhere that does if IS_CHILD_PROXY else gobject code fallback. Reason is that the way it's currently done is weird and breaks stuff for bindings, you can't do childproxy.lookup('foo') but have to do childproxy.lookup(childproxy, 'foo'). It should probably be renamed in any case because "lookup" is a bit too generic a method name really, IMHO.
Created attachment 220940 [details] [review] childproxy: make gst_child_proxy_lookup() a proper GstChildProxy method
Created attachment 220941 [details] [review] parse: fix up for gst_child_proxy_lookup() only working on child proxy interfaces
Looks good and makes sense IMHO
commit 9a38d713bdd594bd5d2b844b8a2fabc53913c828 Author: Tim-Philipp Müller <tim@centricular.net> Date: Sun Aug 12 13:27:06 2012 +0100 parse: fix up for gst_child_proxy_lookup() only working on child proxy interfaces https://bugzilla.gnome.org/show_bug.cgi?id=681681 commit ffa60dc3ee386165820ed1a7f1eb28e2be4ced58 Author: Tim-Philipp Müller <tim@centricular.net> Date: Sun Aug 12 13:24:18 2012 +0100 childproxy: make gst_child_proxy_lookup() a proper GstChildProxy method No longer accept any old GObjects. This makes things nicer for bindings. If a utility function that handles both nicely is deemed worthwhile, we can still add one to gstutils. https://bugzilla.gnome.org/show_bug.cgi?id=681681