GNOME Bugzilla – Bug 330723
Various components shouldn't include their role in their accessible name.
Last modified: 2013-09-13 00:53:26 UTC
As a followup to bug #330712, we've found several other places where the accessible name for a widget contains its role. Listed below are the source filenames where these string occur, plus the suggested string to use in its place. -- ./calendar/gui/e-calendar-table.c atk_object_set_name (a11y, _("Task Table")); Suggest replacing this with "Tasks" -- ./calendar/gui/e-memo-table.c atk_object_set_name (a11y, _("Memo Table")); Suggest replacing this with "Memos" -- ./calendar/gui/dialogs/comp-editor.c atk_object_set_name (gtk_widget_get_accessible (priv->attachment_expander), _("Attachment Button: Press space key to toggle attachment bar")); Suggest replacing this with "Show Attachments" but also adding in an accessible description. In other words, also add in the line: atk_object_set_description (gtk_widget_get_accessible (priv->attachment_expander), _("Press space key to toggle attachment bar")); -- ./mail/em-account-prefs.c atk_object_set_name (gtk_widget_get_accessible (table), _("Mail Accounts Table")); Suggest replacing this with "Mail Accounts" -- ./mail/em-format-html-display.c atk_object_set_name (a11y, _("Attachment Button")); Suggest replacing this with "Attachment" -- atk_object_set_name (gtk_widget_get_accessible (priv->arrow), _("Toggle Attachment Bar")); Suggest replacing this with "Show Attachments" -- ./mail/message-list.c atk_object_set_name(a11y, _("Message List")); Suggest replacing this with "Messages" -- ./plugins/itip-formatter/itip-formatter.c atk_object_set_name (gtk_widget_get_accessible (ess), _("Conflict Search Table")); Suggest replacing this with "Conflict Search" -- ./widgets/misc/e-calendar.c atk_object_set_name (a11y, _("Previous Button")); Suggest replacing this with "Previous" atk_object_set_name (a11y, _("Previous Button")); Suggest replacing this with "Previous" -- ./widgets/misc/e-dateedit.c atk_object_set_name (a11y, _("Date and Time Entry")); Suggest replacing this with "Date and Time" atk_object_set_name (a11y, _("Text Date Entry")); Suggest replacing this with "Date" atk_object_set_name (a11y, _("Date Button")); Suggest replacing this with "Date" atk_object_set_name (a11y, _("Time Combo Box")); Suggest replacing this with "Time" -- ./widgets/misc/e-search-bar.c atk_object_set_name (a11y, _("Search Text Entry")); Suggest replacing this with "Search" -- Thanks!
Created attachment 59107 [details] [review] proposed fix, calendar part
Created attachment 59108 [details] [review] proposed fix, mail part
Created attachment 59109 [details] [review] proposed fix, plugins part
Created attachment 59110 [details] [review] proposed fix, widgets part
Changes look good. Thanks!
Committed to HEAD. Sending announcements soon.