GNOME Bugzilla – Bug 773497
vaapi: miscellaneous code style fixes
Last modified: 2016-10-31 14:35:55 UTC
These patches are not related directly to a specific bug, but rather they are cleanups to the code, somewhat required for further developments.
Created attachment 338434 [details] [review] plugins: simplify code Merge two lines of variable declarations.
Created attachment 338435 [details] [review] encode: h264, h265: rename long name So encoder and decoders have the same codec name.
Created attachment 338436 [details] [review] vaapivideomemory: rename input parameter In order to clarify the use of flag as input parameter, it is renamed to surface_alloc_flag, since it is used when creating a VA surface with certain properties.
Created attachment 338437 [details] [review] vaapivideomemory: comment style
Created attachment 338438 [details] [review] plugins: fix code style for errors
Created attachment 338439 [details] [review] vaapidecode: rename member to allowed_sinkpad_caps vaapidecode has a member named allowed_caps, but this name is not enough explicit. This patch renames allowed_caps to allowed_sinkpad_caps. No functional changes were included. https://bugzilla.gnome.org/show_bug.cgi?id=772838
Created attachment 338440 [details] [review] vaapipostproc: use GST_*_OBJECT when possible Since we can have several vaapipostproc operating in a pipeline, it is useful to know which one is generating the logging message.
Created attachment 338445 [details] [review] plugins: simplify code Merge two lines of variable declarations.
Created attachment 338446 [details] [review] vaapiencode: h264, h265: rename codec name So encoder and decoders have the same codec name.
Created attachment 338447 [details] [review] vaapidecode: rename long name So encoders and decoders have similar long names.
Created attachment 338448 [details] [review] vaapivideomemory: rename input parameter In order to clarify the use of flag as input parameter, it is renamed to surface_alloc_flag, since it is used when creating a VA surface with certain properties.
Created attachment 338449 [details] [review] vaapivideomemory: comment style
Created attachment 338450 [details] [review] plugins: fix code style for errors
Created attachment 338451 [details] [review] vaapidecode: rename member to allowed_sinkpad_caps vaapidecode has a member named allowed_caps, but this name is not enough explicit. This patch renames allowed_caps to allowed_sinkpad_caps. No functional changes were included.
Created attachment 338452 [details] [review] vaapipostproc: use GST_*_OBJECT when possible Since we can have several vaapipostproc operating in a pipeline, it is useful to know which one is generating the logging message.
Attachment 338445 [details] pushed as 4f4e0a8 - plugins: simplify code Attachment 338446 [details] pushed as 43dd4b7 - vaapiencode: h264, h265: rename codec name Attachment 338448 [details] pushed as 289a8e5 - vaapivideomemory: rename input parameter Attachment 338449 [details] pushed as 34e8579 - vaapivideomemory: comment style Attachment 338450 [details] pushed as 0f938be - plugins: fix code style for errors Attachment 338451 [details] pushed as c258343 - vaapidecode: rename member to allowed_sinkpad_caps Attachment 338452 [details] pushed as bb0abb1 - vaapipostproc: use GST_*_OBJECT when possible