After an evaluation, GNOME has moved from Bugzilla to GitLab. Learn more about GitLab.
No new issues can be reported in GNOME Bugzilla anymore.
To report an issue in a GNOME project, go to GNOME GitLab.
Do not go to GNOME Gitlab for: Bluefish, Doxygen, GnuCash, GStreamer, java-gnome, LDTP, NetworkManager, Tomboy.
Bug 747293 - audiodecoder: Add sink and src query virtual method
audiodecoder: Add sink and src query virtual method
Status: RESOLVED FIXED
Product: GStreamer
Classification: Platform
Component: gst-plugins-base
git master
Other All
: Normal enhancement
: 1.5.1
Assigned To: GStreamer Maintainers
GStreamer Maintainers
Depends on:
Blocks:
 
 
Reported: 2015-04-03 10:11 UTC by Wonchul Lee
Modified: 2015-04-23 18:47 UTC
See Also:
GNOME target: ---
GNOME version: ---


Attachments
audiodecoder: Add sink and src query virtual method (13.29 KB, patch)
2015-04-03 10:13 UTC, Wonchul Lee
none Details | Review
audiodecoder: Add sink and src query virtual method (6.84 KB, patch)
2015-04-03 11:19 UTC, Wonchul Lee
committed Details | Review

Description Wonchul Lee 2015-04-03 10:11:14 UTC
I just add sink_query() / src_query() virtual method for audio decoder.
I thought implementing some custom query for omx audio decoders, it can make it easy to handle queries.
Comment 1 Wonchul Lee 2015-04-03 10:13:02 UTC
Created attachment 300876 [details] [review]
audiodecoder: Add sink and src query virtual method
Comment 2 Tim-Philipp Müller 2015-04-03 10:17:21 UTC
Comment on attachment 300876 [details] [review]
audiodecoder: Add sink and src query virtual method

>-      if (!(res = gst_audio_encoded_audio_convert (&dec->priv->ctx.info,
>+      if (!(res = gst_audio_encoded_audio_convert (&decoder->priv->ctx.info,

It looks like your patch is larger than necessary because you chose to call the decoder variable 'decoder' instead of 'dec' in the query_default function, which necessitates unrelated changes. Please rename it to 'dec' in order to minimise the diff.
Comment 3 Wonchul Lee 2015-04-03 11:19:10 UTC
Created attachment 300881 [details] [review]
audiodecoder: Add sink and src query virtual method

I changed the name of decoder variable 'decoder' to 'dec'. Thank you.
Comment 4 Tim-Philipp Müller 2015-04-23 18:47:12 UTC
Thanks, pushed with minor cosmetic changes (used pad as object for debug logging in some places; use GST_OBJECT_CAST instead of GST_OBJECT when calling pad default function; header indentation; moved one comment back to where it was originally; added 'Since 1.6' to gtk-doc comment):

commit 5dffb8a3117ba08f0a10b0f3949b6d178a468668
Author: Wonchul Lee <chul0812@gmail.com>
Date:   Fri Apr 3 00:44:12 2015 +0900

    audiodecoder: Add sink and src query virtual method
    
    API: GstAudioDecoderClass::src_query()
    API: GstAudioDecoderClass::sink_query()
    
    https://bugzilla.gnome.org/show_bug.cgi?id=747293